Back to overview
Maintenance
System updates
Nov 18 at 12:45pm MST
–
Nov 18 at 04:45pm MST
Affected services
Platform
Crucible Challenges
Resolved
Nov 18 at 12:45pm MST
Platform updates and maintenance.
Affected services
Resolved
Nov 18 at 12:45pm MST
Platform updates and maintenance.
Affected services